<!doctype html>
<html class="no-js" lang="en-US">

<head>
  <meta charset="UTF-8" />
<script type="text/javascript">
var gform;gform||(document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0}),gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),gform.hooks[o][n].push({tag:i,callable:r,priority:t=null==t?10:t})},doHook:function(n,o,r){var t;if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[n][o]&&((o=gform.hooks[n][o]).sort(function(o,n){return o.priority-n.priority}),o.forEach(function(o){"function"!=typeof(t=o.callable)&&(t=window[t]),"action"==n?t.apply(null,r):r[0]=t.apply(null,r)})),"filter"==n)return r[0]},removeHook:function(o,n,t,i){var r;null!=gform.hooks[o][n]&&(r=(r=gform.hooks[o][n]).filter(function(o,n,r){return!!(null!=i&&i!=o.tag||null!=t&&t!=o.priority)}),gform.hooks[o][n]=r)}});
</script>

  <meta name="viewport" content="width=device-width, initial-scale=1.0" />
  <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v18.1 (Yoast SEO v18.3) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Fake Drake Challenges Real Drake to $1 Million Boxing Match - Rap-Up</title>
	<link rel="canonical" href="https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Fake Drake Challenges Real Drake to $1 Million Boxing Match" />
	<meta property="og:url" content="https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/" />
	<meta property="og:site_name" content="Rap-Up" />
	<meta property="article:publisher" content="https://www.facebook.com/rapup" />
	<meta property="article:modified_time" content="2022-06-29T18:23:23+00:00" />
	<meta property="og:image" content="https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma.jpg" />
	<meta property="og:image:width" content="1020" />
	<meta property="og:image:height" content="534" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:site" content="@rapup" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rap-up.com/#organization","name":"Rap-Up","url":"https://www.rap-up.com/","sameAs":["https://www.facebook.com/rapup","https://www.instagram.com/rapup","https://www.youtube.com/rapuptv","https://en.wikipedia.org/wiki/Rap-Up","https://twitter.com/rapup"],"logo":{"@type":"ImageObject","@id":"https://www.rap-up.com/#logo","inLanguage":"en-US","url":"https://www.rap-up.com/wp-content/uploads/2022/06/logo-black.png","contentUrl":"https://www.rap-up.com/wp-content/uploads/2022/06/logo-black.png","width":170,"height":54,"caption":"Rap-Up"},"image":{"@id":"https://www.rap-up.com/#logo"}},{"@type":"WebSite","@id":"https://www.rap-up.com/#website","url":"https://www.rap-up.com/","name":"Rap-Up","description":"Hip-Hop and R&amp;B Music, News, Photos, Interviews, &amp; Videos","publisher":{"@id":"https://www.rap-up.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rap-up.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#primaryimage","inLanguage":"en-US","url":"https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma.jpg","contentUrl":"https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma.jpg","width":1020,"height":534,"caption":"Fake Drake and Drake"},{"@type":"WebPage","@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#webpage","url":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/","name":"Fake Drake Challenges Real Drake to $1 Million Boxing Match - Rap-Up","isPartOf":{"@id":"https://www.rap-up.com/#website"},"primaryImageOfPage":{"@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#primaryimage"},"datePublished":"2022-06-29T18:18:37+00:00","dateModified":"2022-06-29T18:23:23+00:00","breadcrumb":{"@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rap-up.com/"},{"@type":"ListItem","position":2,"name":"Fake Drake Challenges Real Drake to $1 Million Boxing Match"}]},{"@type":"NewsArticle","@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#article","isPartOf":{"@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#webpage"},"author":{"@id":"https://www.rap-up.com/#/schema/person/a94dc6a4343551c8d9ede411073d1bd8"},"headline":"Fake Drake Challenges Real Drake to $1 Million Boxing Match","datePublished":"2022-06-29T18:18:37+00:00","dateModified":"2022-06-29T18:23:23+00:00","mainEntityOfPage":{"@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#webpage"},"wordCount":9,"publisher":{"@id":"https://www.rap-up.com/#organization"},"image":{"@id":"https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#primaryimage"},"thumbnailUrl":"https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma.jpg","keywords":["Drake"],"articleSection":["News"],"inLanguage":"en-US","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.rap-up.com/#organization"}},{"@type":"Person","@id":"https://www.rap-up.com/#/schema/person/a94dc6a4343551c8d9ede411073d1bd8","name":"Devin","image":{"@type":"ImageObject","@id":"https://www.rap-up.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ec5784a485a918def43e14382d2d8f74?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/ec5784a485a918def43e14382d2d8f74?s=96&d=mm&r=g","caption":"Devin"},"url":"https://www.rap-up.com/author/devin/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel="amphtml" href="https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/?amp" /><meta name="generator" content="AMP for WP 1.0.77.38"/><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//www.rap-up.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link href='//www.rap-up.com' rel='preconnect' />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.rap-up.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='safetag-css'  href='https://www.rap-up.com/wp-content/plugins/safetag/public/css/safetag-public.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/slick/slick.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='slick-theme-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/slick/slick-theme.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/magnific-popup.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_login-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/loginform.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_sign_up-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/regform.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_single_video-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/single_video.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_subscribe_button-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/subscription_button.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_plans-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/plans.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype_change_credit_card-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/zype_forms/auth/change_credit_card.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='zype-style-css'  href='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/css/style_plugin.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='oswald-fonts-css'  href='https://fonts.googleapis.com/css2?family=Oswald%3Awght%40700&#038;display=swap&#038;ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='main-stylesheet-css'  href='https://www.rap-up.com/wp-content/themes/sloth/dist/css/app.css?ver=2022.06.23' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js?ver=3.2.1' id='jquery-js'></script>
<script type='text/javascript' id='safetag-js-extra'>
/* <![CDATA[ */
var safetag_config = {"post_id":"343927"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/safetag/public/js/safetag-public.js?ver=1.0.2' id='safetag-js'></script>
<script type='text/javascript' id='providers-js-extra'>
/* <![CDATA[ */
var cpm_object = {"ajaxurl":"https:\/\/www.rap-up.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/st_base/vc_extend/providers/assets/js/providers.js?ver=5.9.1' id='providers-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/imaskjs.min.js?ver=2.6.4' id='zype_checkoutSuccess-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/stripe.js?ver=2.6.4' id='zype_stripe_api-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/dropin.min.js?ver=2.6.4' id='zype_braintree_api-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/checkout.js?ver=2.6.4' id='zype_checkout-js'></script>
<script type='text/javascript' src='//cdn.jsdelivr.net/npm/slick-carousel@1.8.1/slick/slick.min.js?ver=5.9.1' id='slick-js'></script>
<link rel="https://api.w.org/" href="https://www.rap-up.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rap-up.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rap-up.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.rap-up.com/?p=343927' />
<link rel="alternate" type="application/json+oembed" href="https://www.rap-up.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rap-up.com%2F2022%2F06%2F29%2Ffake-drake-challenges-real-drake-1-million-boxing-match%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rap-up.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rap-up.com%2F2022%2F06%2F29%2Ffake-drake-challenges-real-drake-1-million-boxing-match%2F&#038;format=xml" />
			<meta property="fb:pages" content="40433812843" />
							<meta property="ia:markup_url" content="https://www.rap-up.com/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/?ia_markup=1" />
				<!-- HFCM by 99 Robots - Snippet # 1: Google site tag -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2716866-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2716866-1');
</script>

<!-- /end HFCM by 99 Robots -->
<!-- HFCM by 99 Robots - Snippet # 4: IAB CCPA -->
	<script src= "https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>

<!-- /end HFCM by 99 Robots -->
<!-- HFCM by 99 Robots - Snippet # 11: OneTrust Cookies Consent Notice (Live) -->
<!-- OneTrust Cookies Consent Notice start for www.rap-up.com -->

<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="dfae105a-097a-4a6a-856c-9d47e38fe054" ></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>
<!-- OneTrust Cookies Consent Notice end for www.rap-up.com -->
<!-- /end HFCM by 99 Robots -->
<!-- HFCM by 99 Robots - Snippet # 12: Google Site Verification -->
<meta name="google-site-verification" content="hg8TJjxD0R_w7C1yMhSQlqwYmfhi3W3LpVJNMA5wJNs" />
<!-- /end HFCM by 99 Robots -->
<style type="text/css">#zype_video__auth-close, #zype_video__auth-close:hover{color:#AAAAAA;}body .zype-custom-modal{background-color:#FFFFFF;}.zype-column-plans{border-color:#D9D8E0;background-color:#FFFFFF;}.zype-custom-title{color:#272424;}.zype-type-plan{color:#272424;}.zype-title-plan{color:#60626B;}.zype-price-holder{color:#60626B;}div.zype-form-center .zype-custom-button, .play-trailer-button .zype-btn-container-plan, div.zype-form-center .zype-btn-container-plan, .user-profile-wrap__button.zype-custom-button{color:#00A5DF;border-color:#00A5DF;background-color:#FFFFFF;}div.zype-form-center .zype-custom-button:hover, .play-trailer-button .zype-btn-container-plan:hover, div.zype-form-center .zype-btn-container-plan:hover, .user-profile-wrap__button.zype-custom-button:hover{color:#00A5DF;border-color:#00A5DF;background-color:#FFFFFF;}div.zype-form-center .zype-custom-button:focus, .play-trailer-button .zype-btn-container-plan:focus, div.zype-form-center .zype-btn-container-plan:focus, .user-profile-wrap__button.zype-custom-button:focus{color:#00A5DF;border-color:#00A5DF;background-color:#FFFFFF;}.zype-custom-button:hover{color:#00A5DF;border-color:#00A5DF;background-color:#FFFFFF;}.slick-arrow:before{color:#C9CFD8;}.slider_links .slider_links-title a{color:#45484C;}.slider_links .slider_links-title a:focus,
                .slider_links .slider_links-title a:active,
                .slider_links .slider_links-title a:hover{color:#6E7075;}.get-all-playlists.slider_links-all a{color:#9D9FA5;}.get-all-playlists.slider_links-all a:focus,
                .get-all-playlists.slider_links-all a:active,
                .get-all-playlists.slider_links-all a:hover{color:#BFC3CB;}.item_title_block{color:#5B5E64;}</style>		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://www.rap-up.com/wp-content/uploads/2022/05/rap-up-favicon-100x100.png" sizes="32x32" />
<link rel="icon" href="https://www.rap-up.com/wp-content/uploads/2022/05/rap-up-favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rap-up.com/wp-content/uploads/2022/05/rap-up-favicon.png" />
<meta name="msapplication-TileImage" content="https://www.rap-up.com/wp-content/uploads/2022/05/rap-up-favicon.png" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>  <!-- Connatix Head Script -->
  <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.src='javascript:false'; t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js?cid=deaad9ad-3cb1-41ec-a455-1732a1c49825',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>
  <!-- end of Connatix Head Script -->
  <!-- adGrid Ad Begin Header Tag -->
  <script>
    window.top.adGrid = window.top.adGrid || {};
    window.top.adGrid.cmd = window.top.adGrid.cmd || [];

    var adGridInitiate = function() {
      this.adGridCall(function() {
        var pageMeta = {};
        this.setMetaDataFromPage(pageMeta);
      })
    };

    window.top.adGrid.cmd.push([adGridInitiate]);
  </script>
  <!-- adGrid Ad End Header Tag -->

  <!-- Taboola Head code -->
  <script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
      if (!document.getElementById(i)){
        e.async = 1;
        e.src = u;
        e.id = i;
        f.parentNode.insertBefore(e, f);
      }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/rapup/loader.js',
    'tb_loader_script');
    if(window.performance && typeof window.performance.mark == 'function')
      {window.performance.mark('tbl_ic');}
  </script>
  <!-- Taboola Head code -->

  </head>

<body class="article-template-default single single-article postid-343927 no-banner offcanvas wpb-js-composer js-comp-ver-6.8.0 vc_responsive">

        
  <div class="small-menu-wrapper bg-black position-absolute-full position-fixed color-white pb-12 h-hide-for-large" id="small-menu-wrapper" data-toggler=".expanded" role="navigation" aria-label="Mobile menu">
    <div class="row align-right mt-16">
      <div class="column shrink">
        <a class="close-button position-relative display-block" data-toggle="small-menu-wrapper"><span aria-hidden="true">×</span></a>
      </div>
    </div>
    <div class="row morganite-e-bold text-uppercase">
      <div class="column">
        <div class="sm-man-nav">
          <ul id="menu-main-menu" class="dropdown menu desktop-menu" data-dropdown-menu><li id="menu-item-343079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-article-ancestor current-menu-parent current-article-parent menu-item-343079"><a href="https://www.rap-up.com/category/news/">News</a></li>
<li id="menu-item-163855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163855"><a href="https://www.rap-up.com/category/new-music/">Music</a></li>
<li id="menu-item-163853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163853"><a href="https://www.rap-up.com/category/videos/">Videos</a></li>
<li id="menu-item-163361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163361"><a href="https://www.rap-up.com/rap-up-tv-landing/">Rap-Up TV</a></li>
</ul>        </div>
        <div class="flex-container mt-16 tmb-48 smb-48">
          <a href="https://www.rap-up.com/?s=" class="mobile-search search-button" aria-label="Search Icon"><i class="icon-rm-search"></i></a>
        </div>
        <div>
          <div class="agp-reg sm-text-14-18 text-14-18 text-uppercase global-letter-spacing">find us on /</div>
          <div class="h-social">
            <ul id="menu-social-menu" class="dropdown menu desktop-menu" data-dropdown-menu><li id="menu-item-6860" class="s-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-6860"><a href="https://www.facebook.com/rapup/">FB</a></li>
<li id="menu-item-6862" class="s-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-6862"><a href="https://twitter.com/rapup/">Twitter</a></li>
<li id="menu-item-6861" class="s-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-6861"><a href="https://instagram.com/rapup/">Instagram</a></li>
<li id="menu-item-6863" class="s-youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-6863"><a href="https://www.youtube.com/user/RapUpTV">Youtube</a></li>
<li id="menu-item-148353" class="s-snapchat menu-item menu-item-type-custom menu-item-object-custom menu-item-148353"><a href="https://www.snapchat.com/add/rap-up">Snapchat</a></li>
</ul>          </div>
        </div>
      </div>
    </div>
  </div>
  <!-- Pre Header Ads Placement -->
  <div class="no-full top-ad-wrapper" id="top-ad-wrapper">
    
		<div class="hide-for-small-only dark-grey ">
	  <div class="adgrid ad_leaderboard_banner_page" data-adgrid-iuparts="/22558110666/rap-up.com/site/970x250">
	  </div>
	</div>

		<div class="show-for-small-only dark-grey ">
	  <div class="adgrid ad_leaderboard_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/mobile_320x50">
	  </div>
	</div>
  </div>
  <!-- end of Pre Header Ads Placement -->
  <header class="header agp-light sticky-header  no-header-top" id="header">
    <div class="row align-middle full-height">
      <div class="columns shrink logo">
        <a href="https://www.rap-up.com/" rel="home" class="display-block position-relative">
          <img   alt="Wrap-up Regular Logo" data-src="https://www.rap-up.com/wp-content/themes/sloth/dist/images/logo-black.png" class="regular-menu-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="regular-menu-logo" src="https://www.rap-up.com/wp-content/themes/sloth/dist/images/logo-black.png" alt="Wrap-up Regular Logo" /></noscript>

                      <img   alt="Wrap-up Sticky Logo" data-src="https://www.rap-up.com/wp-content/themes/sloth/dist/images/logo-white.png" class="sticky-menu-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="sticky-menu-logo" src="https://www.rap-up.com/wp-content/themes/sloth/dist/images/logo-white.png" alt="Wrap-up Sticky Logo" /></noscript>
                  </a>
      </div>
      <div class="columns flex-container align-middle h-show-for-large">
        <div class="main-nav">
          <ul id="menu-main-menu-1" class="dropdown menu desktop-menu" data-dropdown-menu><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-article-ancestor current-menu-parent current-article-parent menu-item-343079"><a href="https://www.rap-up.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163855"><a href="https://www.rap-up.com/category/new-music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163853"><a href="https://www.rap-up.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163361"><a href="https://www.rap-up.com/rap-up-tv-landing/">Rap-Up TV</a></li>
</ul>        </div>
      </div>
      <div class="columns flex-container align-middle shrink h-show-for-large">
        <div class="header-search">
          <a href="javascript:void(0);" class="flex-container align-middle align-center search-button" aria-label="Search Icon"><i class="icon-rm-search"></i></a>
        </div>
        <div class="h-social">
          <ul id="menu-social-menu-1" class="dropdown menu desktop-menu" data-dropdown-menu><li class="s-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-6860"><a href="https://www.facebook.com/rapup/">FB</a></li>
<li class="s-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-6862"><a href="https://twitter.com/rapup/">Twitter</a></li>
<li class="s-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-6861"><a href="https://instagram.com/rapup/">Instagram</a></li>
<li class="s-youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-6863"><a href="https://www.youtube.com/user/RapUpTV">Youtube</a></li>
<li class="s-snapchat menu-item menu-item-type-custom menu-item-object-custom menu-item-148353"><a href="https://www.snapchat.com/add/rap-up">Snapchat</a></li>
</ul>        </div>
      </div>
      <a class="menu-opener h-hide-for-large" data-toggle="small-menu-wrapper"><span class="text-hide">Menu</span></a>
    </div>
    <div class="search-form-wrapper bg-white pt-32 pb-32" id="search-form-wrapper">
      <div class="row">
        <div class="columns">
          
<form role="search" method="get" class="search-form" action="https://www.rap-up.com/">
  <div class="input-group">
    <input type="text" class="input-group-field" value="" name="s" aria-label="Search" placeholder="Search">
    <div class="input-group-button">
      <input type="submit" value="Search" class="button has-border">
    </div>
  </div>
</form>
        </div>
        <div class="columns shrink">
          <button class="close-button black position-relative search-button" type="button">
            <span aria-hidden="true">×</span>
          </button>
        </div>
      </div>
    </div>
        <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>
      </header>

<div class="main-container">

  <main class="main-content">
              <article id="post-343927" class="mt-24 post-343927 article type-article status-publish has-post-thumbnail hentry category-news tag-drake artist-drake">
    <div class='sections pt-112'>
    <div class="row">
      <div class="columns">
                  <div class="row  mb-32">
                              <div class='section-text regular columns'>
                    <div class="mb-32">
      <div class='banner-eyebrow text-14-18 text-uppercase agp-light mb-12 color-red'><a href='https://www.rap-up.com/category/news/' class='no-color'>News</a></div>
              <div class="article-banner-in-content text-center mb-20 position-relative">
        <div class="display-inline-block position-relative">
          <img  alt="Fake Drake and Drake" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma-1014x531.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://www.rap-up.com/wp-content/uploads/2022/06/fake-drake-bbma-1014x531.jpg" alt="Fake Drake and Drake"></noscript>
                            </div>
      </div>
        <h1 class=''>Fake Drake Challenges Real Drake to $1 Million Boxing Match</h1>
  
  <div class="row">
    <div class="columns mt-8">
              <div class="row collapse color-dark-gray text-14-18 text-uppercase agp-reg">
          <div class="yml-byline l-height-26 sl-height-26">
            By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
          </div>
          <div class="yml-originally_published_on l-height-26 sl-height-26">&nbsp;&nbsp;/&nbsp;&nbsp;06.29.2022</div>
        </div>
          </div>
    <div class="columns shrink mt-8">
      <div class="social-items ">
	<div class="addthis_inline_share_toolbox"></div>
</div>
    </div>
  </div>
</div>
<p>Fake Drake wants to get in the ring with real Drake.</p>
<p>The <a href="https://www.rap-up.com/2021/11/16/drake-impersonator-gets-paid-for-appearances/">internet famous</a> impersonator, who goes by IzzyyDrake on Instagram, is challenging his idol to a $1 million &#8220;friendly boxing match.&#8221;</p>
<p>According to <a href="https://www.tmz.com/2022/06/29/fake-drake-celebrity-boxing-instagram-one-million-dollars/" rel="noopener" target="_blank">TMZ</a>, boxing promoter Damon Feldman of Celebrity Boxing signed the Drake look-alike and booked a fight for an Aug. 27 event, whether Drake fights him or not.</p>
<p>If fake Drake wins, Izzyy wants Drake to pay him $1 million and sign him to OVO Sound. If fake Drake is knocked out, he has agreed to stop impersonating the real Drake. </p>
<p><iframe title="Fake Drake Enters (His Own) Terms of Celebrity Boxing Real Drake | TMZ" width="500" height="281"  frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/oc1ps9T696Y?feature=oembed" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<p>Fake Drake, who also hails from Toronto, has been making a career off impersonating the “Jimmy Cooks” rapper. He has been releasing his own music, including his recent single <a href="https://www.youtube.com/watch?v=RnvHi0tq8ZQ" rel="noopener" target="_blank">&#8220;Attack of the Clones,&#8221;</a> and <a href="https://www.rap-up.com/2021/11/16/drake-impersonator-gets-paid-for-appearances/">reportedly</a> gets paid $5000 for appearances. </p>
<p>The self-proclaimed “viral overnight” sensation, who has 150,000 Instagram followers, claims that Drake is not concerned about his imposter. “Drake was just like, ‘It doesn’t bother me. It doesn’t affect me, let the guy get his bag. It isn’t affecting me,&#8217;” he told the “No Jumper” podcast. “He didn’t really give a f**k.”</p>
<p>But not everyone has welcomed him. Fake Drake was recently kicked out of one of Drake&#8217;s favorite Houston nightclubs for impersonating the 6 God. The real Drake seemed to approve by liking the headline on Instagram.</p>
<p><center></p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/tv/CfAGEQwgpBO/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/tv/CfAGEQwgpBO/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/tv/CfAGEQwgpBO/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by DJ Akademiks (@akademiks)</a></p>
</div>
</blockquote>
<p> <script async src="//www.instagram.com/embed.js"></script></center></p>
                  </div>
                                      <div class='columns shrink a-sider'>
                                            <div class="mb-32 no-full hide-for-small-only ">
		<div class="hide-for-small-only light-grey ">
	  <div class="adgrid ad_rightrail" data-adgrid-iuparts="/22558110666/rap-up.com/site/rr_300x250">
	  </div>
	</div>

		<div class="show-for-small-only light-grey ">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
</div>
                                                <div class="hide-for-small-only"><div class="">
      <h2 class="text-uppercase agp-bold text-25-37 border-tb-black text-center mb-16 section-title-black">YOU MIGHT ALSO LIKE</h2>
        <div class="card type-inline border-b-black mb-16">
                <a href="https://www.rap-up.com/2022/06/28/drake-celebrates-11-no-1-albums-singles/" aria-label="Drake Celebrates After Earning His 11th No. 1 Album and Single">
            <div class="item-image ratio-1x1 bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/drake-tb-322x215.jpg"></div>
          </a>
        
        <div class="card-content">
                      <h3 class="title oswald-bold text-25-37 mb-16 text-center mb-0"><a href="https://www.rap-up.com/2022/06/28/drake-celebrates-11-no-1-albums-singles/">Drake Celebrates After Earning His 11th No. 1 Album and Single</a></h3>
                    <div class="row hide collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                          <div class="yml-byline columns shrink l-height-26">
                By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
              </div>
                                      <div class="yml-originally_published_on columns shrink l-height-26">&nbsp;&nbsp;/&nbsp;&nbsp;06.28.2022</div>
                      </div>
        </div>
    </div>
      <div class="card type-inline border-b-black mb-16">
                <a href="https://www.rap-up.com/2022/06/27/drake-honestly-nevermind-debuts-at-no-1/" aria-label="Drake Earns 11th No. 1 Album With 'Honestly, Nevermind'">
            <div class="item-image ratio-1x1 bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/drake-bbma-322x215.jpg"></div>
          </a>
        
        <div class="card-content">
                      <h3 class="title oswald-bold text-25-37 mb-16 text-center mb-0"><a href="https://www.rap-up.com/2022/06/27/drake-honestly-nevermind-debuts-at-no-1/">Drake Earns 11th No. 1 Album With 'Honestly, Nevermind'</a></h3>
                    <div class="row hide collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                          <div class="yml-byline columns shrink l-height-26">
                By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
              </div>
                                      <div class="yml-originally_published_on columns shrink l-height-26">&nbsp;&nbsp;/&nbsp;&nbsp;06.27.2022</div>
                      </div>
        </div>
    </div>
      <a href="https://www.rap-up.com/category/news/" class="button expanded has-border mb-32 has-arrow hide">View More</a>
    </div>
</div>
                                                <div class="stick-item">
		<div class="hide-for-small-only light-grey ">
	  <div class="adgrid ad_rightrail" data-adgrid-iuparts="/22558110666/rap-up.com/site/rr_300x250">
	  </div>
	</div>

		<div class="show-for-small-only light-grey ">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
</div>
                                          </div>
                            </div>
                        <div class="row">
                <div class="column">
                  <div class='post-tags color-dark-gray text-uppercase agp-reg mb-32 smb-32'>
            <div class='bedge black display-inline-block text-14-18'>
         <a href="https://www.rap-up.com/category/news/">
                      News        </a>
      </div>
                                <div class='bedge black display-inline-block text-14-18'>
         <a href="https://www.rap-up.com/artist/drake/">
                      Drake        </a>
      </div>
      </div>
                </div>
                <div class="columns small-12 mb-24">
                  <div class="rt-main-content">
                    <div class="a-ad-wrapper border-tb-black">
		<div class="hide-for-small-only light-grey ">
	  <div class="adgrid ad_leaderboard" data-adgrid-iuparts="/22558110666/rap-up.com/site/728x90">
	  </div>
	</div>

		<div class="show-for-small-only light-grey ">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
</div> <div class="yml-container rt_full_width_content border-bottom">
      <div class="border-bottom title-wrapper rt_full_width_content">
      <div class="row align-middle">
        <div class="columns">
          <h2 class="text-capitalize agp-reg mb-0 text-24-31">TRENDING</h2>
        </div>
      </div>
    </div>
      <div class="row ">
    <div class="columns small-full-width t-full-width pt-32 has-black-no-gap">
      <div class="can_load_more">
          <div class="row card list-view">
    <div class="columns small-12 medium-5 large-7 smb-25">
              <a href="https://www.rap-up.com/2021/12/16/justine-skye-exposes-giveon-cheating/">
          <div class="item-image position-relative responsive-embed widescreen bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/04/justine-skye-giveon-1.jpg">
                    </div>
        </a>
          </div>
    <div class="columns small-12 medium-7 large-5">
                    <div class="item-eyebrow text-14-18 global-letter-spacing text-uppercase color-red agp-light mb-16">
          <a href="https://www.rap-up.com/category/news/" class="no-color">News</a>
        </div>
                          <h3 class="title agp-reg text-24-31 mb-16"><a href="https://www.rap-up.com/2021/12/16/justine-skye-exposes-giveon-cheating/">Justine Skye Exposes Giveon for Cheating on Her</a></h3>
                        <div class="row collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                  <div class="yml-byline columns shrink l-height-26 hide">
            By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
          </div>
                          <div class="yml-originally_published_on columns shrink l-height-26">12.16.2021</div>
              </div>
    </div>
  </div>
  <div class="row card list-view">
    <div class="columns small-12 medium-5 large-7 smb-25">
              <a href="https://www.rap-up.com/2022/06/23/megan-thee-stallion-signed-with-jay-z-hot-cheetos/">
          <div class="item-image position-relative responsive-embed widescreen bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/megan-stallion-jay-z-553x314.jpg">
                    </div>
        </a>
          </div>
    <div class="columns small-12 medium-7 large-5">
                    <div class="item-eyebrow text-14-18 global-letter-spacing text-uppercase color-red agp-light mb-16">
          <a href="https://www.rap-up.com/category/news/" class="no-color">News</a>
        </div>
                          <h3 class="title agp-reg text-24-31 mb-16"><a href="https://www.rap-up.com/2022/06/23/megan-thee-stallion-signed-with-jay-z-hot-cheetos/">Megan Thee Stallion Signed With JAY-Z After He Surprised Her With Hot Cheetos</a></h3>
                        <div class="row collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                  <div class="yml-byline columns shrink l-height-26 hide">
            By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
          </div>
                          <div class="yml-originally_published_on columns shrink l-height-26">06.23.2022</div>
              </div>
    </div>
  </div>
  <div class="row card list-view">
    <div class="columns small-12 medium-5 large-7 smb-25">
              <a href="https://www.rap-up.com/2022/06/26/chris-brown-weighs-in-verzuz-usher/">
          <div class="item-image position-relative responsive-embed widescreen bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/chris-brown-usher-553x314.jpg">
                    </div>
        </a>
          </div>
    <div class="columns small-12 medium-7 large-5">
                    <div class="item-eyebrow text-14-18 global-letter-spacing text-uppercase color-red agp-light mb-16">
          <a href="https://www.rap-up.com/category/news/" class="no-color">News</a>
        </div>
                          <h3 class="title agp-reg text-24-31 mb-16"><a href="https://www.rap-up.com/2022/06/26/chris-brown-weighs-in-verzuz-usher/">Chris Brown Weighs In On Verzuz Battle with Usher</a></h3>
                        <div class="row collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                  <div class="yml-byline columns shrink l-height-26 hide">
            By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
          </div>
                          <div class="yml-originally_published_on columns shrink l-height-26">06.26.2022</div>
              </div>
    </div>
  </div>
  <div class="row card list-view">
    <div class="columns small-12 medium-5 large-7 smb-25">
              <a href="https://www.rap-up.com/2022/06/27/diddy-honored-lifetime-achievement-kanye-west-bet-awards/">
          <div class="item-image position-relative responsive-embed widescreen bg-cover mb-0 st-lazy-load-bg" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/diddy-ba2022-553x314.jpg">
                    </div>
        </a>
          </div>
    <div class="columns small-12 medium-7 large-5">
                    <div class="item-eyebrow text-14-18 global-letter-spacing text-uppercase color-red agp-light mb-16">
          <a href="https://www.rap-up.com/category/news/" class="no-color">News</a>
        </div>
                          <h3 class="title agp-reg text-24-31 mb-16"><a href="https://www.rap-up.com/2022/06/27/diddy-honored-lifetime-achievement-kanye-west-bet-awards/">Diddy Honored With Lifetime Achievement Award, Receives Tributes From Kanye West, JAY-Z</a></h3>
                        <div class="row collapse color-dark-gray text-14-18 text-uppercase agp-reg">
                  <div class="yml-byline columns shrink l-height-26 hide">
            By <a class="no-color" href="https://www.rap-up.com/author/devin/">Devin</a>
          </div>
                          <div class="yml-originally_published_on columns shrink l-height-26">06.27.2022</div>
              </div>
    </div>
  </div>
      </div>
                  <a href="https://www.rap-up.com/?s=" class="button expanded has-border mb-32 has-arrow">View More</a>
            </div>
    <div class="columns shrink small-full-width t-full-width pt-32 border-left small-no-border t-no-border has-ad-sidebar pb-32">
      <div class="stick-item">
        
		<div class="hide-for-small-only light-grey ">
	  <div class="adgrid ad_rightrail" data-adgrid-iuparts="/22558110666/rap-up.com/site/rr_300x250">
	  </div>
	</div>

		<div class="show-for-small-only light-grey ">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
      </div>
    </div>
  </div>
  </div>
                  </div>
                </div>
              </div>
              <div class="row">
                <div class="columns">
                  <!-- Taboola widget -->
                  <div class="title-wrapper border-bottom">
                    <div class="row align-middle">
                      <div class="columns">
                        <h2 class="text-uppercase agp-reg mb-0 text-24-31 entry-title">Sponsored Stories</h2>
                      </div>
                    </div>
                  </div>
                  <div id="taboola-below-article-thumbnails"></div>
                  <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({
                      mode: 'thumbnails-a',
                      container: 'taboola-below-article-thumbnails',
                      placement: 'Below Article Thumbnails',
                      target_type: 'mix'
                    });
                  </script>
                  <!-- end of Taboola widget -->
                </div>
                <div class="columns shrink a-sider">
                  <div class='stick-item'>
                  
		<div class="hide-for-small-only  ">
	  <div class="adgrid ad_rightrail" data-adgrid-iuparts="/22558110666/rap-up.com/site/rr_300x250">
	  </div>
	</div>

		<div class="show-for-small-only  ">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
                  </div>
                </div>
              </div>
                    </div>
    </div>
  </div>
  </article>
<!-- Connatix Playspace -->
<div class="row">
	<div class="column">
		<script id="b844bc06f5964e1db15b64cf217a60df">(new Image()).src = 'https://capi.connatix.com/tr/si?token=fbcab8d2-fa4d-4411-9f83-b160ba37e859&cid=deaad9ad-3cb1-41ec-a455-1732a1c49825';  cnxps.cmd.push(function () {    cnxps({      playerId: "fbcab8d2-fa4d-4411-9f83-b160ba37e859"    }).render("b844bc06f5964e1db15b64cf217a60df");  });</script>
	</div>
</div>
      </main>

  <aside class="sidebar">
  </aside>
</div>

  <div class="a-ad-wrapper border-tb-black no-full">
    
		<div class="hide-for-small-only light-grey has-border">
	  <div class="adgrid ad_leaderboard" data-adgrid-iuparts="/22558110666/rap-up.com/site/728x90">
	  </div>
	</div>

		<div class="show-for-small-only light-grey has-border">
	  <div class="adgrid ad_medium_rectangle_mob" data-adgrid-iuparts="/22558110666/rap-up.com/site/incontent_300x250">
	  </div>
	</div>
  </div>
<footer class="footer bg-white color-black agp-light">
  <div class="row">
    <div class="columns footer-nav">
      <section id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-6876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6876"><a>Terms and Policy</a>
<ul class="sub-menu">
	<li id="menu-item-6867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6867"><a href="https://www.rap-up.com/terms-of-use/">Terms of Use</a></li>
	<li id="menu-item-6866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6866"><a href="https://www.rap-up.com/privacy-notice/">Privacy Notice</a></li>
	<li id="menu-item-343737" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-343737"><a href="/cookie-policy">COOKIE POLICY</a></li>
	<li id="menu-item-109769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-109769"><a href="/contact">Cookie Preference</a></li>
</ul>
</li>
<li id="menu-item-6877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6877"><a>Ask Us</a>
<ul class="sub-menu">
	<li id="menu-item-6871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6871"><a href="https://www.rap-up.com/contact-us/">Email RAP-UP</a></li>
	<li id="menu-item-7551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7551"><a href="/contact/?option=tip">Send us a tip</a></li>
	<li id="menu-item-77185" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77185"><a href="/contact/?option=personal&#038;support=donotsell">Information protection</a></li>
</ul>
</li>
</ul></div></section>    </div>
    <div class="columns small-3 footer-social show-for-large">
      <div class="display-inline-block" id="footer-social-widget">
        <section id="text-3" class="widget widget_text"><h6>Find us on</h6>			<div class="textwidget"><p><img  alt="Rap-Up" data-src="https://www.rap-up.com/wp-content/uploads/2022/06/logo-black.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://www.rap-up.com/wp-content/uploads/2022/06/logo-black.png" alt="Rap-Up" /></noscript></p>
</div>
		</section><section id="nav_menu-3" class="widget widget_nav_menu"><div class="menu-social-menu-container"><ul id="menu-social-menu-2" class="menu"><li class="s-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-6860"><a href="https://www.facebook.com/rapup/">FB</a></li>
<li class="s-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-6862"><a href="https://twitter.com/rapup/">Twitter</a></li>
<li class="s-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-6861"><a href="https://instagram.com/rapup/">Instagram</a></li>
<li class="s-youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-6863"><a href="https://www.youtube.com/user/RapUpTV">Youtube</a></li>
<li class="s-snapchat menu-item menu-item-type-custom menu-item-object-custom menu-item-148353"><a href="https://www.snapchat.com/add/rap-up">Snapchat</a></li>
</ul></div></section>      </div>
    </div>
    <div class="columns small-12 copyright text-center text-uppercase">
      <section id="text-2" class="widget widget_text">			<div class="textwidget"><p>© 2022 Rap-up All rights reserved.</p>
</div>
		</section>    </div>
  </div>
</footer>

  <!-- </div> --><!-- Close off-canvas content -->
  <!-- commented out the div as this is marked by w3c compliance as a stray div -->

<div class="reveal" id="subscription-modal" data-reveal>
	<script type="text/javascript"></script>
                <div class='gf_browser_unknown gform_wrapper gravity-theme subscription_form_wrapper' id='gform_wrapper_1' ><div id='gf_1' class='gform_anchor' tabindex='-1'></div>
                        <div class='gform_heading'>
                            <span class='gform_description'></span>
                        </div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_1' id='gform_1' class='subscription_form' action='/2022/06/29/fake-drake-challenges-real-drake-1-million-boxing-match/#gf_1' >
                        <div class='gform_body gform-body'><div id='gform_fields_1' class='gform_fields top_label form_sublabel_below description_below'><div id="field_1_1" class="gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible" ><div class="subscription-top">
  <div class="row">
    <div class="columns small-12 medium-6 flex-container align-top">
      <div class="bg-white img"><img  alt="Rap-Up Mini Logo" data-src="/wp-content/uploads/2022/05/r-logo.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="/wp-content/uploads/2022/05/r-logo.png" alt="Rap-Up Mini Logo"></noscript></div>
      <div class="morganite-e-bold global-letter-spacing2 text-78 text-uppercase title">Subscribe</div>
    </div>
    <div class="columns small-12 medium-6">
      <div class="agp-reg text-20 text">Get the best of REVOLT in your inbox.</div>
    </div>
  </div>
</div></div><div id="field_1_2" class="gfield gfield--width-full gfield_contains_required field_sublabel_below field_description_below hidden_label gfield_visibility_visible" ><label class='gfield_label' for='input_1_2' >Email<span class="gfield_required"><span class="gfield_required gfield_required_text">(Required)</span></span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_2' id='input_1_2' type='text' value='' class='large'   placeholder='Enter Email Address' aria-required="true" aria-invalid="false" aria-describedby="gfield_description_1_2" />
                        </div><div class='gfield_description' id='gfield_description_1_2'>By signing up, you agree to our Privacy Notice and European users agree to the data transfer policy.</div></div><fieldset id="field_1_4" class="gfield gfield--width-full field_sublabel_below field_description_below gfield_visibility_visible" ><legend class='gfield_label screen-reader-text gfield_label_before_complex'  ></legend><div class='ginput_container ginput_container_checkbox'><div class='gfield_checkbox' id='input_1_4'><div class='gchoice gchoice_1_4_1'>
								<input class='gfield-choice-input' name='input_4.1' type='checkbox'  value='Tv Shows'  id='choice_1_4_1'   />
								<label for='choice_1_4_1' id='label_1_4_1'>Tv Shows</label>
							</div><div class='gchoice gchoice_1_4_2'>
								<input class='gfield-choice-input' name='input_4.2' type='checkbox'  value='New Music'  id='choice_1_4_2'   />
								<label for='choice_1_4_2' id='label_1_4_2'>New Music</label>
							</div><div class='gchoice gchoice_1_4_3'>
								<input class='gfield-choice-input' name='input_4.3' type='checkbox'  value='Interviews'  id='choice_1_4_3'   />
								<label for='choice_1_4_3' id='label_1_4_3'>Interviews</label>
							</div><div class='gchoice gchoice_1_4_4'>
								<input class='gfield-choice-input' name='input_4.4' type='checkbox'  value='Social Justice'  id='choice_1_4_4'   />
								<label for='choice_1_4_4' id='label_1_4_4'>Social Justice</label>
							</div><div class='gchoice gchoice_1_4_5'>
								<input class='gfield-choice-input' name='input_4.5' type='checkbox'  value='Black News'  id='choice_1_4_5'   />
								<label for='choice_1_4_5' id='label_1_4_5'>Black News</label>
							</div><div class='gchoice gchoice_1_4_6'>
								<input class='gfield-choice-input' name='input_4.6' type='checkbox'  value='Newsletters' checked='checked' id='choice_1_4_6'   />
								<label for='choice_1_4_6' id='label_1_4_6'>Newsletters</label>
							</div></div></div></fieldset><div id="field_1_5" class="gfield gfield--width-full field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label screen-reader-text' for='input_1_5' ></label><div id='input_1_5' class='ginput_container ginput_recaptcha' data-sitekey='6LfwpwggAAAAAFGJJTzBSF7vrRKefFm0bJhos7jt'  data-theme='light' data-tabindex='-1' data-size='invisible' data-badge='bottomright'></div></div></div></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_1' class='gform_button button' value='Submit'  onclick='if(window["gf_submitting_1"]){return false;}  window["gf_submitting_1"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_1"]){return false;} window["gf_submitting_1"]=true;  jQuery("#gform_1").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=1&amp;title=&amp;description=1&amp;tabindex=0' />
            <input type='hidden' class='gform_hidden' name='is_submit_1' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='1' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_1' value='WyJbXSIsIjBjMGYzMGQ0OWQ1OGRlYmIxZTYzMWZjZmExN2ViODQ4Il0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_1' id='gform_target_page_number_1' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_1' id='gform_source_page_number_1' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_1' id='gform_ajax_frame_1' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
                <script type="text/javascript">
gform.initializeOnLoaded( function() {gformInitSpinner( 1, 'https://www.rap-up.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery('#gform_ajax_frame_1').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_1');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_1').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_1').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_1').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_1').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_1').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_1').val();gformInitSpinner( 1, 'https://www.rap-up.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery(document).trigger('gform_page_loaded', [1, current_page]);window['gf_submitting_1'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_1').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_1').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [1]);window['gf_submitting_1'] = false;wp.a11y.speak(jQuery('#gform_confirmation_message_1').text());}, 50);}else{jQuery('#gform_1').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [1, current_page]);} );} );
</script>
  <button class="close-button" data-close aria-label="Close modal" type="button">
    <span aria-hidden="true">&times;</span>
  </button>
</div>
<!-- HFCM by 99 Robots - Snippet # 6: ComScore Global Tag -->
<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7513696" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = "https://sb.scorecardresearch.com/cs/7513696/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=7513696&amp;cv=3.6.0&amp;cj=1">
</noscript>
<!-- End comScore Tag -->
<!-- /end HFCM by 99 Robots -->
<!-- start zype_wp_js_env -->
<script type="text/javascript">
    var zype_js_wp_env = {
        plugin_url: 'https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/resources/views',
        home_url: 'https://www.rap-up.com/',
        logout_url: 'https://www.rap-up.com/sign-out',
        profile_url: 'https://www.rap-up.com/profile',
        auth_url: 'https://www.rap-up.com/sign-in',
        ajax_endpoint: 'https://www.rap-up.com/wp-admin/admin-ajax.php',
        logged_in: false,
        estWidgetEnabled: true,
    };
</script>
<!-- end zype_wp_js_env -->
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/zype_wp.js?ver=2.6.4' id='zype_wp_js-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/slick/slick.js?ver=2.6.4' id='slick-js-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/slider.js?ver=2.6.4' id='slider-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/zype-wordpress-plugin-master/dist/javascripts/jquery.magnific-popup.min.js?ver=2.6.4' id='magnific-popup-js-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.*)sitemap(.*).xml|\/(.*)sitemap.xsl|\/article-sitemap164.xml|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.rap-up.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/themes/sloth/dist/js/app.js?ver=2022.06.23' id='foundation-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.3.0' id='jquery-form-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js?ver=3.9.7' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-content/plugins/theia-smart-thumbnails-premium/dist/js/tst-frontend.js?ver=2.2.3' id='theiaSmartThumbnails-frontend.js-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/dom-ready.min.js?ver=ecda74de0221e1c2ce5c57cbb5af09d5' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://www.rap-up.com/wp-includes/js/dist/a11y.min.js?ver=68e470cf840f69530e9db3be229ad4b6' id='wp-a11y-js'></script>
<script type='text/javascript' defer='defer' src='https://www.rap-up.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.5.16.4' id='gform_json-js'></script>
<script type='text/javascript' id='gform_gravityforms-js-extra'>
/* <![CDATA[ */
var gform_i18n = {"datepicker":{"days":{"monday":"Mon","tuesday":"Tue","wednesday":"Wed","thursday":"Thu","friday":"Fri","saturday":"Sat","sunday":"Sun"},"months":{"january":"January","february":"February","march":"March","april":"April","may":"May","june":"June","july":"July","august":"August","september":"September","october":"October","november":"November","december":"December"},"firstDay":1,"iconText":"Select date"}};
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2,"code":"USD"},"base_url":"https:\/\/www.rap-up.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.rap-up.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
var gf_legacy_multi = {"1":""};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='https://www.rap-up.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.5.16.4' id='gform_gravityforms-js'></script>
<script type='text/javascript' defer='defer' src='https://www.google.com/recaptcha/api.js?hl=en&#038;ver=5.9.1#038;render=explicit' id='gform_recaptcha-js'></script>
<script type='text/javascript' defer='defer' src='https://www.rap-up.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.5.16.4' id='gform_placeholder-js'></script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 1) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [1, 1]) } );
</script>
        <script>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</script>
        <script async src="https://console.adgrid.io/adgrid-build/ad-grid-rap-up-com.js"></script>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-62755979b591779c"></script>
<!-- tracking code for articles -->
<!-- tracking code for articles -->
<!-- Data for Ads -->
<script>
  window.adgrid_gkv = {
    id: 343927,
    title: "Fake Drake Challenges Real Drake to $1 Million Boxing Match",
        tags: ["Drake"],
            category: ["News"],
                type: "article",
              }
</script>
<!-- Adhesion Ad for Desktop and tablet. -->
<div class="hide-for-small-only">
  <div class="adgrid ad_adhesion_desktop" data-adgrid-iuparts="/22558110666/rap-up.com/site/adhesion_728x91"></div>
</div>
<!-- end of Adhesion Ad for Desktop and Tablet. -->

<!-- Adhesion Ad for Mobile. -->
<div class="show-for-small-only">
  <div class="adgrid ad_adhesion" data-adgrid-iuparts="/22558110666/rap-up.com/site/adhesion_320x51"></div>
</div>
<!-- end Adhesion Ad Mobile. -->
<!-- Out of Page. -->
<div class="adgrid ad_out_of_page" data-adgrid-iuparts="/22558110666/rap-up.com/site/1x1"></div>
<!-- end of Out of Page. -->
<!-- end of Data for Ads -->
<!-- Taboola Footer code -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<!-- Taboola Footer code -->
</body>
</html>
